WordPress needs to have the correct permissions to write files to your site otherwise it will not be able to update themes or plugins for you.

For some servers, file system access is available, the files are owned by your user, but the webserver doesn’t run as your user, and so WordPress does not detect the automatic update correctly.

When this occurs you will be asked to give your FTP login information so that WordPress can login via FTP to run the update. WP Remote uses FTPs to pass this information securely.

Unfortunately if you are asked for your FTP information and do not know it then it will not be possible to run the update.